Preguntas frecuentes de ALDOS.

¿Por qué ALDOS se abstiene de usar SystemD?

SystemD es una implementación que añade una funcionalidad de gestión de servicios y sistema a Linux del mismo modo que lo hace LaunchD en mac OS. Ofrece muchas ventajas al gestionar los servicios por dependencias entre éstos y permite iniciar el sistema en menor tiempo que un sistema operativo con SysV. Pero todo éso tiene como costo un incremento considerable en el consumo de recursos de sistema.

ALDOS por defecto, recién iniciado y con los servicios predeterminados, utiliza alrededor de 475 MB de RAM. Una instalación similar de Fedora con SystemD utiliza alrededor de 825 MB RAM. Para los sistemas modernos que vienen equipados con 4 u 8 GB RAM, probablemente haga poca diferencia, pero en sistemas de legado que tienen 1 o 2 GB RAM, ahorrar casi 400 MB RAM hace una gran diferencia.

¿Cómo hago para instalar X aplicación que está ausente de la colección de software de ALDOS?

ALDOS incluye de modo predeterminado flatpak. Permite instalar casi todo el software relevante disponible en Flathub.org.

Para activar Flathub, es necesario ejecutar como root lo siguiente:

flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

Para instalar cualquier paquete de Flathub como root o como usuario regular, sólo es necesario buscar la aplicación deseada en Flathub.org y ejecutar la instrucción que se incluye al final de cada página. Ejemplo para instalar Spotify para Linux:

flatpak install flathub com.spotify.Client

Por favor, evite instalar aplicaciones que de Flathub que sí existan en ALDOS. Nosotros procuramos incluir todas las aplicaciones libres posibles y compilar éstas de manera nativa con todas las funciones que técnicamente nos sean posibles. Las aplicaciones Flatpak son una excelente forma de instalar software de última generación, pero utilizan más espacio de almacenamiento y algunas suelen ir compiladas con menos funciones que las aplicaciones nativas.

¿Por qué sólo distribuyen imagen ISO para sistemas Intel/AMD de 64 bits?

  1. Muchas aplicaciones relevantes ―como Google Chrome, Spotify, Telegram Desktop, Darktable― sólo tienen soporte para 64bits.
  2. Quedan muy pocos sistemas de 32 bits.
  3. Las arquitectura Intel/AMD de 32 bits es muy lenta para las aplicaciones modernas.
  4. Sólo disponemos de presupuesto para darle soporte a la arquitectura Intel/AMD de 64 bits.

Estamos abiertos brindar soporte para la arquitectura ARM64 y otras arquitecturas, pero ―nuevamente― sólo disponemos de presupuesto para darle soporte a la arquitectura Intel/AMD de 64 bits.

¿Cómo habilito el planificador de entrada y salida BFQ?

Siga las instrucciones descritas en este artículo publicado. Sólo requiere añadir scsi_mod.use_blk_mq=1 a los argumentos de arranque del núcleo de Linux del sistema y crear el archivo /etc/udev/rules.d/60-scheduler.rules con el contenido descrito en ese mismo artículo publicado.

¿Por qué ALDOS utiliza Xfce como escritorio predeterminado?

  1. Xfce en ALDOS utiliza alrededor de 475 MB RAM. ¡Casi la mitad de los que utiliza Cinnamon y alrededor de la tercera parte de lo que utiliza GNOME!
  2. La filosofía de ALDOS es fomentar y preservar la interfaz tradicional del escritorio.
  3. En ALDOS ofrecemos la versión de lo que consideramos debería ser el entorno de escritorio ideal de cuerdo a nuestro criterio.
  4. La huella de carbono de una computadora utilizando Xfce es considerablemente menor que la de una computadora utilizando Cinnamon, GNOME o KDE Plasma. Por tanto, utilizar Xfce es más amigable con el medio ambiente.

LXQt utiliza aún menos recursos de sistema ―menos de 300 MB RAM― que Xfce, pero es menos funcional y con menor integración entre sus componentes.

¿Puedo utilizar en ALDOS otro entorno de escritorio distinto a Xfce?

¡Sí! Están disponibles Cinnamon, MATE, LXQt, KDE Plasma y Lumina Desktop. Adicionalmente puede utilizar los gestores de ventanas Openbox, Fluxbox, Blackbox, Enlightenment 0.16, WindowMaker y IceWM, así como varios compositores Wayland que incluyen Sway, Wayfire y Labwc. De éstos últimos, el más fácil de utilizar es Labwc, el resto requiere memorizar docenas de atajos de teclado.

Para instalar Cinnamon, ejecute como root:

yum groupinstall cinnamon-desktop

Para instalar MATE, ejecute como root:

yum groupinstall mate-desktop

Para instalar KDE Plasma, ejecute como root:

yum groupinstall kde-desktop

Para instalar LXQt, ejecute como root:

yum groupinstall lxqt-desktop

Para instalar Lumina Desktop, ejecute como root:

yum install lumina-desktop

¿Cuál es el entorno de escritorio más avanzado y sofisticado disponible en ALDOS?

Hay dos opciones muy buenas: Cinnamon y KDE Plasma.

¿Puedo utilizar GNOME en ALDOS?

Sí, pero sólo la versión 3.34 de GNOME, sin soporte alguno de parte nuestra. Está disponible en el almacén de software ALDOS-Plus. GNOME tiene como característica tener una muy estrecha dependencia hacia SystemD y ―como ya mencionamos― ALDOS es una distribución libre de SystemD. Los desarrolladores de GNOME carecen de interés alguno en que dicho entorno de escritorio funcione en sistemas operativos distintos a Linux con SystemD y Wayland. Así que GNOME 3.34 es lo máximo que podemos ofrecer en ALDOS.

Todo lo esencial de GNOME funcionará en la versión 3.34 disponible en ALDOS, excepto la pantalla de bloqueo al suspender o hibernar el sistema.

¿Puedo utilizar ALDOS como servidor?

Sí. Sólo recuerde que el enfoque de ALDOS es funcionar como sistema operativo de escritorio. ALDOS está optimizado de modo predeterminado para funcionar como sistema operativo de escritorio, es decir con latencia moderada. Los servidores requieren funcionar como latencia completa. Puede hacer ajustes al sistema para funcionar como servidor utilizando Tuned. Procuramos incluir versiones recientes y con soporte de largo plazo para Nginx, PHP, MariaDB, etc.

Una aplicación me pide utilizar Python 3.7 o posterior. ¿Qué puedo hacer?

ALDOS utiliza por defecto Python 3.6. Actualizar la versión de Python en un sistema operativo implica volver a compilar alrededor de 1200 paquetes de software. ¡Implica mucho trabajo! Sin embargo, ya tenemos un creciente conjunto de paquetes que permiten instalar Python 3.9 en paralelo con Python 3.6 y que están disponibles en la colección de software de ALDOS desde finales de septiembre 2022.